Elettracompany.com

Компьютерный справочник
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Функция счетесли в excel

Функция СЧЁТЕСЛИ() в MS Excel — Подсчет значений с единственным критерием

Для подсчета ЧИСЛОвых значений, Дат и Текстовых значений, удовлетворяющих определенному критерию, существует простая и эффективная функция СЧЁТЕСЛИ( ) , английская версия COUNTIF(). Подсчитаем значения в диапазоне в случае одного критерия, а также покажем как ее использовать для подсчета неповторяющихся значений и вычисления ранга .

СЧЁТЕСЛИ ( диапазон ; критерий )

Диапазон — диапазон, в котором нужно подсчитать ячейки, содержащие числа, текст или даты.

Критерий — критерий в форме числа, выражения, ссылки на ячейку или текста, который определяет, какие ячейки надо подсчитывать. Например, критерий может быть выражен следующим образом: 32, «32», «>32», «яблоки» или B4 .

Подсчет числовых значений с одним критерием

Данные будем брать из диапазона A15:A25 (см. файл примера ).

Критерий

Формула

Результат

Примечание

4

Подсчитывает количество ячеек, содержащих числа равных или более 10. Критерий указан в формуле

= (ячейка С4)11(ячейка С5)

3

Подсчитывает количество ячеек, содержащих числа равных или более 11. Критерий указан через ссылку и параметр

Примечание . О подсчете значений, удовлетворяющих нескольким критериям читайте в статье Подсчет значений со множественными критериями . О подсчете чисел с более чем 15 значащих цифр читайте статью Подсчет ТЕКСТовых значений с единственным критерием в MS EXCEL .

Подсчет Текстовых значений с одним критерием

Функция СЧЁТЕСЛИ() также годится для подсчета текстовых значений (см. Подсчет ТЕКСТовых значений с единственным критерием в MS EXCEL ).

Подсчет дат с одним критерием

Так как любой дате в MS EXCEL соответствует определенное числовое значение , то настройка функции СЧЕТЕСЛИ() для дат не отличается от рассмотренного выше примера (см. файл примера Лист Даты ).

Если необходимо подсчитать количество дат, принадлежащих определенному месяцу, то нужно создать дополнительный столбец для вычисления месяца, затем записать формулу = СЧЁТЕСЛИ(B20:B30;2)

Подсчет с несколькими условиями

Обычно, в качестве аргумента критерий у функции СЧЁТЕСЛИ() указывают только одно значение. Например, =СЧЁТЕСЛИ(H2:H11;I2) . Если в качестве критерия указать ссылку на целый диапазон ячеек с критериями, то функция вернет массив. В файле примера формула =СЧЁТЕСЛИ(A16:A25;C16:C18) возвращает массив <3:2:5>.

Для ввода формулы выделите диапазон ячеек такого же размера как и диапазон содержащий критерии. В Строке формул введите формулу и нажмите CTRL+SHIFT+ENTER , т.е. введите ее как формулу массива .

Это свойство функции СЧЁТЕСЛИ() используется в статье Отбор уникальных значений .

Специальные случаи использования функции

Возможность задать в качестве критерия несколько значений открывает дополнительные возможности использования функции СЧЁТЕСЛИ() .

В файле примера на листе Специальное применение показано как с помощью функции СЧЁТЕСЛИ() вычислить количество повторов каждого значения в списке.

Выражение СЧЁТЕСЛИ(A6:A14;A6:A14) возвращает массив чисел <1:4:4:4:4:1:3:3:3>, который говорит о том, что значение 1 из списка в диапазоне А6:А15 — единственное, также в диапазоне 4 значения 2, одно значение 3, три значения 4. Это позволяет подсчитать количество неповторяющихся значений формулой =СУММПРОИЗВ(—(СЧЁТЕСЛИ(A6:A14;A6:A14)=1)) .

ШКОЛА ПРОГРАММИРОВАНИЯ

Вы здесь

Сообщение об ошибке

Функции Excel. Функция СУММЕСЛИ(), СЧЁТЕСЛИ()

В статье «Функции Excel. Функция ЕСЛИ» была рассмотрена работа со встроенной функцией ЕСЛИ в Excel, которая позволяет по условию делать тот, или иной расчет. Но у функции есть некоторые ограничения, а именно, невозможно посчитать, например сумму значений по определенному условию или подсчет кол-ва. Для этого в Excel предусмотрены две условные функции суммирования и подсчета кол-ва: СУММЕСЛИ(), СЧЁТЕСЛИ()/

Синтаксис функции СУММЕСЛИ()

Функция СУММЕСЛИ возвращает сумму значений из указанного диапазона ячеек согласно условия. Функция СУММЕСЛИ имеет следующие аргументы:

СУММЕСЛИ ( диапазон ; критерий ; диапазон_суммирования)

  • Диапазон — указывается диапазон ячеек для проверки;
  • Критерий — в критерии может быть указано число, текст или выражение. Критерий указывается следующим образом: 45, «45», «>45″,» 45″, «текст».
  • Диапазон_суммирования — необязательный аргумент. Если аргумент не указан, то суммирование производится по аргументу «Диапазон», если указан, то суммирование значений будет производиться по ячейкам указанным в этом аргументе.
Читать еще:  Линейная интерполяция в excel

Пример 1.

Разберем пример на подсчет суммы. Итак, дана матрица 4х4

Необходимо подсчитать сумму значений, которые меньше 6.

Щелкаем по свободной ячейке, добавляем функцию. Функция СУММЕСЛИ находится в категории «Математические», вносим следующие аргументы:

Жмем «ОК» и смотрим. Результат 25.

Пример 2.

Во втором примере я продемонстрирую еще один вариант подсчета.

Необходимо подсчитать, сколько всего было продано молока.

Вставляем функцию и пишем следующее

В данном варианте я поленился писать критерий и сделал ссылку на ячейку G4, если Вам не лень, то пропишите критерий в кавычках “Молоко”. Результат 79.

Второй вариант. Необходимо подсчитать кол-во товара без учета молока. В этом варианте продемонстрирую, как прописать неравенство и ссылку на ячейку. Добавляем в ячейку E16 следующую формулу

& (амперсанд) – позволяет «склеить» строки. В нашем случае, к знаку неравенства мы присоединяем строку G4. Результат работы функций:

Синтаксис функции СЧЁТЕСЛИ()

Функция СЧЁТЕСЛИ() возвращает количество ячеек(строк) удовлетворяющих указанному критерию.

СЧЁТЕСЛИ ( диапазон ; критерий )

Диапазоны и критерии задаются аналогично функции СУММЕСЛИ.

Примечание: Обратите внимание на написание функции, СЧЁТ пишется именно через Ё, а не через Е. Если написать иначе, функция не будет распознана.

Пример 3

Все та же таблица с наименованием товаров. Необходимо подсчитать кол-во строк «Молоко» в массиве.

В ячейку B14 добавляем функцию СЧЁТЕСЛИ, которая находится в категории «Статистические».

Здесь я так же поленился с вводом критерия Результат следующий:

Вот и все. Функции просты и понятны. Примеры работы в приложенном файле.

Excel: Функции СЧЕТЕСЛИ и СЧЕТЕСЛИМН

В случаях, когда при работе в Excel требуется подсчитать количество ячеек, удовлетворяющих заданному условию, можно использовать функцию Счётесли .

Функция Счётесли

Счётесли (диапазон; критерий)

Диапазон – группа ячеек, для которых нужно выполнить подсчет.

Диапазон может содержать числа, массивы или ссылки на числа.
Обязательный аргумент.

Критерий – число, выражение, ссылка на ячейку или текстовая строка, которая определяет, какие ячейки нужно подсчитать.
Обязательный аргумент.

Критерий проверки необходимо заключать в кавычки.

Критерий не чувствителен к регистру. К примеру, функция не увидит разницы между словами «налог» и «НАЛОГ».

Примеры использования функции Счётесли.

  1. Подсчет количества ячеек, содержащих отрицательные значения

Счётесли(А1:С2;» «&A4) Диапазон — А1:С2 , критерий — «>»&A4

  1. Подсчет количества ячеек со словом «текст» (регистр не имеет значения).

Счётесли(А1:С2;»текст») Диапазон — А1:С2 , критерий — «текст»

  1. Для текстовых значений в критерии можно использовать подстановочные символы * и ? .

Вопросительный знак соответствует одному любому символу,
звездочка— любому количеству произвольных символов.

Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак

Например, чтобы подсчитать количество ячеек, содержащих текст, который начинается с буквы Т (без учета регистра), можно воспользоваться следующей формулой:

Счётесли(А1:С2;»Т * «) Диапазон — А1:С2 , критерий — «Т * «

Если необходимо подсчитать количество ячеек, которые содержат ровно четыре символа, можно использовать формулу:

Счётесли(А1:С2;». «) Диапазон — А1:С2 , критерий — «. «

В функции Счётесли используется только один критерий.

Чтобы провести подсчет по нескольким условиям, необходимо воспользоваться функцией Счётеслимн.

Функция Счётеслимн

Счётеслимн (диапазон1; условие1; [диапазон2]; [условие2]; …).

Функция аналогична функции Счётеслимн, за исключением того, что может содержать до 127 диапазонов и условий, где первое является обязательным, а последующие – нет.

Читать еще:  Excel vba заливка ячейки

Каждый дополнительный диапазон должен состоять из такого же количества строк и столбцов, что и диапазон условия 1. Эти диапазоны могут не находиться рядом друг с другом.

Пример использования:

  1. Подсчет количества ячеек, в которых находятся даты из определенного периода (например, после 15 января и до 1 марта 2015г.).

Счётеслимн(C1:C8;»>15.01.2015″;C1:C8;» 15.01.2015″ и «<1.03.2015"

Понравилось? Поделись с друзьями

Семинары. Вебинары. Конференции

Актуальные темы. Лучшие лекторы Москвы и РФ. Сертификаты ИПБР. Более 30 тематик в месяц.

Функция СЧЕТЕСЛИ в Excel

В этой статье мы сосредоточимся на функции СЧЕТЕСЛИ в Excel, которая предназначена для подсчета ячеек с указанным вами условием. Во-первых, мы кратко рассмотрим синтаксис и общее использование, а затем приведем ряд примеров функции СЧЕТЕСЛИ.

По сути, функция СЧЕТЕСЛИ на английском COUNTIF, идентична во всех версиях Excel, поэтому вы можете использовать примеры из этого руководства в Excel 2016, 2013, 2010 и 2007.

Синтаксис и использование функции СЧЕТЕСЛИ в Excel

Функция СЧЕТЕСЛИ в Excel используется для подсчета ячеек в пределах заданного диапазона, которые соответствуют определенному критерию или условию.

Например, вы можете использовать функцию СЧЕТЕСЛИ, чтобы узнать, сколько ячеек на вашем листе содержит число больше или меньше указанного вами числа. Другое типичное использование функции СЧЕТЕСЛИ в Excel — подсчет ячеек с определенным словом или началом с конкретной буквы (букв).

Синтаксис функции СЧЕТЕСЛИ очень прост:

Как видите, есть только 2 аргумента функции СЧЕТЕСЛИ, оба из которых обязательны:

  • диапазон – определяет одну или несколько ячеек для подсчета. Вы помещаете диапазон в формулу, как обычно, в Excel, например. A1:A20.
  • критерии – определяет условие, которое сообщает функции, которую подсчитывают ячейки. Это может быть число, текстовая строка, ссылка на ячейку или выражение (например, «10», A2, «>=10»).

Вот простейший пример функции СЧЕТЕСЛИ в Excel. Формула =СЧЁТЕСЛИ(C2:C7;»Иванов Иван») подсчитывает, сколько заявок поступало от Иванова Ивана:

Функция СЧЕТЕСЛИ в Excel – Пример использования функции СЧЕТЕСЛИ в Excel

Примечание : Критерий нечувствителен к регистру, что означает, что если вы наберете «иванов иван» в качестве критерия в приведенной выше формуле СЧЕТЕСЛИ, это приведет к такому же результату.

Функция СЧЕТЕСЛИ в Excel – примеры

Синтаксис функции СЧЕТЕСЛИ очень прост, однако он допускает множество возможных вариантов критериев, включая подстановочные знаки, значения других ячеек и даже другие функции Excel.

Функция СЧЕТЕСЛИ в Excel для текста и чисел (точное совпадение)

Выше мы рассмотрели пример функции СЧЕТЕСЛИ, которая подсчитывает текстовые значения, соответствующие определенному критерию.

Вместо ввода текста вы можете использовать ссылку на любую ячейку , содержащую это слово или слова, и получить абсолютно одинаковые результаты, например: =СЧЕТЕСЛИ(С1:С7; С2).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ со ссылкой на ячейку

Аналогичные формулы СЧЕТЕСЛИ работают для чисел , также как для текстовых значений.

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел

На изображении выше формула =СЧЁТЕСЛИ(B2:B7;10) учитывает ячейки с количеством 10 в столбце D.

Чтобы подсчитать ячейки со значениями больше, меньше или равными указанному вами числу, вы просто добавляете соответствующий логический оператор к критериям.

Обратите внимание, что в функции СЧЕТЕСЛИ оператор с числом всегда заключен в кавычки, например, =СЧЕТЕСЛИ(B2:B7; «>=10»).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел с логическим оператором

Функция СЧЕТЕСЛИ с подстановочными знаками (частичное совпадение)

Если данные Excel содержат несколько вариантов ключевых слов, которые вы хотите подсчитать, вы можете использовать подстановочный знак в функции СЧЕТЕСЛИ для подсчета всех ячеек, содержащих определенное слово, фразу или буквы, как часть содержимого ячейки.

Читать еще:  Счётеслимн excel примеры

Предположим, у вас есть список цветов, и вы хотите узнать количество цветов, в названии которых содержится слово «синий». Поскольку эти цвета можно написать несколькими разными способами, мы вводим «*синий*» в качестве критериев поиска =СЧЕТЕСЛИ(B2:B8;»*синий*»).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с частичным совпадением

Звездочка (*) используется в функции СЧЕТЕСЛИ для поиска ячеек с любой последовательностью ведущих и конечных символов, как показано в приведенном выше примере. Если вам нужно сопоставить какой-либо один символ, введите вместо него знак вопроса (?) , например, =СЧЁТЕСЛИ(A2:A7;»ст?л»).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с подстановочным знаком

В данном случае функция СЧЕТЕСЛИ вернет значение 2, так как найдет «стол» и «стул».

Функция СЧЁТЕСЛИ в Excel

Доброго времени суток друзья!

Вот и снова пришла очередь рассказать о еще одной полезной функции в табличном редакторе, это функция СЧЕТЕСЛИ в Excel. В моих статьях вы уже встречали функции похожего направления, такие как СУММЕСЛИ, СЧЁТ, ЕСЛИ, их работа в чём-то сродни как работает функция СЧЕТЕСЛИ в Excel, но условия исполнения и специфика всё же отличаются, а поэтому и ситуации для применения также отличаются.

Для чего же собственно такая функция нужна и где ее применение будет наиболее актуальным, а она нужна, для того чтобы сосчитать текстовые значения, числовые значения в массивах данных и даты, которые соответствуют указанному вами критерию.

Важно! Функция СЧЕТЕСЛИ в Excel производит подсчёт только по одному критерию, в случае, когда вам нужно произвести подсчёт множества критериев вам сможет помочь функция СЧЁТЕСЛИМН.

Я думаю, что надо стоить изучить функцию СЧЕТЕСЛИ с ее синтаксиса:

= СЧЕТЕСЛИ(диапазон; критерий), где все критерии обязательные и обозначают:

диапазон – эта определенная вами группа ячеек, в которой вы будете производить подсчёт согласно нужных вам критериев. В диапазон могут входить текстовые ячейки и пустые значения, игнорироваться они не будут. Сам диапазон может в себе содержать массивы, поименованный диапазон, разнообразные числа и ссылки на них;

критерий – это выражение, текстовое значение, ссылка на ячейку или число, то есть любое значение, которое может определить, что же именно нужно найти и какие ячейки будет считать. К примеру, критерий может выглядеть как «40», «=>40», «С65», «менеджер».

Рассмотрим на примере с числами, у нас, к примеру, есть перечень продавцов, которые вот всё продавали и продавали и в конце года, ну представьте себе на минутку, некоторым решили выплатить премию за самоотверженную работу, а то и вообще разбить премию на несколько уровней и найти сколько достойных для получения в зависимости от набраных баллов. Выглядит это так:

=СЧЕТЕСЛИ(C2:C10;»>=100″), в критериях мы используем символы и числа;

=СЧЕТЕСЛИ(C2:C10;$E$8), здесь в критериях мы используем ссылку на условие. Надеюсь моя статья о том, как работает функция СЧЕТЕСЛИ в Excel вам пригодилась, вы почерпнули с нее нужную вам информацию и успешно использовали ее в своей работе!

Если вам интересна иная функции вы можете в комментариях или на сайте написать что именно вас интересует и я напишу обзор)))…. или загляните в «Справочник функций». Пишите, ставьте лайки!

До новых встреч!

«Слаб духом тот, кому богатство не по силам.
»
Л.А. Сенека

Ссылка на основную публикацию
Adblock
detector